API Explorer Page on Dashboard Throws "Error! API Error. Please contact support if the problem persists"

Overview

Upon visiting the API Explorer tab under Applications > APIs > Auth0 Management API in the dashboard, a user sees the following error:

"Error! API Error. Please contact support if the problem persists"

Applies To

  • API Explorer
  • API Error

Cause

This error was due to a specific condition when there is an empty or invalid Action trigger for client credentials exchange flow. 

Here is the setup:

  1. Create a custom action with whitespace in the code.
  2. Deploy it as an M2M flow trigger.
  3. Revisit the API Explorer tab.

Solution

Empty or invalid action trigger code will prevent the client credentials flow. Removing or fixing the offending action trigger resolves the issue.

 

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