AWS SES or SMTP Blocked or Flagged by Office365 Outlook Email Server

Overview

After proper configuration of AWS SES or SMTP as an email provider, some successfully sent emails do not get delivered to the intended recipient inbox or are flagged as spam when the email server for the recipient is an Office365 Outlook server.

 

The email is blocked as spam, and the header contains entries similar to the following: 

smtp.mailfrom=eu-west-1.amazonses.com; dkim=fail (body hash did not verify)
header.d=apps.everstream.ai;dmarc=fail action=quarantine
header.from=apps.everstream.ai;compauth=none reason=454
Received-SPF: Pass (protection.outlook.com: domain of eu-west-1.amazonses.com

 

Applies To
  • Outlook
  • AWS SES
Cause

This is an Office365 Outlook server-specific issue based on their own spam filtering system. 

Solution

To troubleshoot this issue, please follow the below steps: 

  1. Ensure all custom email provider settings are correct in Auth0.
  2. Check DKIM and DRMARC settings in AWS and follow the instructions on that service (Amazon SES).
  3. Trigger the same email directly from the AWS console and outside of it.
  4. Send the same email to other users with various email servers such as Gmail or Apple.

 

For further assistance, please contact Outlook.com - Microsoft Support. 

Recommended content

No recommended content found...