Adaptive MFA PhoneNumber Assessment

Overview

After setting up Adaptive Multifactor Authentication (MFA), there is a new assessor called PhoneNumber Assessment, which appears to only return the following assessment during a normal username/password login transaction. The phone assessment looks like the following:
 

"PhoneNumber": {
"confidence": "neutral",
"code": "phone_number_not_provided"
}


This article explains whether this new assessor impacts how Adaptive MFA functions for regular user logins that do not involve a phone number and whether Adaptive MFA will review the phone numbers input for Phone Message MFA and deliver a confidence score.

Applies To
  • Adaptive Multifactor Authentication (MFA)
  • Assessors
Cause

The new "PhoneNumber assessment" is used in the login flow where the phone number is the main identifier of the user, such as the SMS Passwordless connection.

Solution

In a standard username/password login flow, the assessment result is expected to be phone_number_not_provided. Additionally, Adaptive MFA's Phone Number Assessment will only evaluate SMS Passwordless authentication at this time; the phone number input for SMS/Phone Message MFA is not evaluated by Adaptive MFA.

If this additional functionality would be useful, please consider opening a Feature Request on the Auth0 Community site which is regularly reviewed by the Auth0 Product Team.

 

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