Arbitrary Custom Script Names in Database Connections
Last Updated:
Overview
Specifying arbitrary custom script names within options.customScripts is no longer allowed. This restriction means that only custom script names for custom database-related operations formally supported by the service are allowed within the custom scripts object.
For example, the following was previously allowed when creating or updating database connections even though the service would not associate or use the xyz_script for any custom database operation.
{
"options": {
"customScripts": {
"login": "function login(email, password, callback) {}",
"get_user": "function get_user(email, callback) {}",
"xyz_script": "function xyz() {}"
}
}
}
Attempts to create (POST) or update (PATCH) a connection via the Management API while specifying an unsupported script name will fail with a 400 status code and an error response similar to the following:
{
"statusCode": 400,
"error": "Bad Request",
"message": "Payload validation error: 'Additional properties not allowed: xyz_script' on property customScripts (A map of scripts used to integrate with a custom database).",
"errorCode": "invalid_body"
}
Management operations available through the Dashboard may also fail if attempted for a database connection that defines an unsupported script name.
The case-sensitive script names formally supported by the service are available in the API documentation of relevant endpoints. For example, for the endpoint to create a connection.
Applies To
- Management API
- Connections
Cause
The service imposed additional constraints when creating or updating custom scripts for connections as part of a calendar year 2025 scheduled change to improve the overall experience and consistency around connection configuration.
Tenants with connections using invalid custom script names received multiple notifications about the planned change between March and September 2025. Starting in mid-October 2025, those tenants will no longer be able to update connections with invalid custom script names.
Solution
Management API requests to create or update connections must specify only valid custom script names within the options.customScripts field.
For existing connections that have invalid custom script names, the invalid custom script name properties must be removed. Given the service ignored unsupported script names from a functional perspective, their removal should not cause any impact. However, if an arbitrary custom script name to store a previous version of a supported script is used, transition to alternate means of achieving similar requirements is necessary.