Attempt to create ADFS connection returns "Error! ... Either adfs_server or fedMetadataXml must be set but not both."

Overview

This article explains the cause of the following error while creating an enterprise connection for an existing ADFS metadata URL by providing the metadata URL in the Dashboard.

Error! Something happened while trying to save your connection: Either adfs_server or fedMetadataXml must be set but not both

Applies To

  • Active Directory Federation Services (ADFS)
  • Metadata URL

Cause

This is caused by the metadata URL using an unsafe renegotiation configuration for TLS/SSL. Unsafe renegotiation is not supported after API2 was upgraded to node 18.

Solution

As a quick workaround, load the federation metadata in a browser and then upload it as a file. In the long term, it is recommended to upgrade the OpenSSL/TLS versions running on this host ASAP.

Recommended content

No recommended content found...