Azure AD Error AADSTS900236: The SAML Authentication Request Property 'Subject' is not Supported and Must not Be Set
Last Updated:
Overview
When passing the Subject claim in an AuthnRequest to Azure AD, the following error is returned:
AADSTS900236: The SAML authentication request property 'Subject' is not supported and must not be set.
Applies To
- Azure AD (Entra ID)
- Subject Claims
- AADSTS900236
Cause
This happens because Azure AD does not support Subject claim in the AuthnRequest. See the Microsoft documentation Subject for more information
Solution
Remove the Subject tag from the SAML request template because Azure AD does not support this tag from being sent.
Passing a login_hint to Azure using a SAML connection is not supported.