Change Email Address Domain for Tenant Members when using Google SSO

Overview

This article addresses how to manage tenant member accounts when a company's email domain changes, particularly when tenant members use Google Single Sign-On (SSO) for login.

Applies To
  • Auth0 Dashboard

  • Tenant Members

  • Google Social Connection

Cause

It is not possible to change the email address associated with an Auth0 account.

Solution

If tenant members change their email addresses and lose access to their old Google accounts, they can no longer log in to the Dashboard. This issue occurs when using the Continue with Google button.

The recommended action is to re-invite all tenant members using their new email addresses and remove the old accounts from the tenant members list. For instructions, see Update Dashboard User Email Addresses

NOTE: As a preventative measure, create an account that logs in with an email/password connection and add it as an administrator to the tenants in advance. If all Single Sign-On (SSO) administrators lose access, this admin account can be used to re-invite all members with their new email domains. For instructions, see Add Tenant Members.

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