Error Occurs When Using Self-Managed Custom Domain with Cloudflare
Last Updated:
Overview
Users may encounters an error when using a self-managed custom domain provided by Cloudflare. The following error message is displayed:
You've requested a page on a website (<auth.example.com>) that is on the Cloudflare network. An unknown error occurred while rendering the page.
Applies To
-
Self-managed custom domains
-
Cloudflare
Cause
For self-managed custom domains, this issue originates from the custom domain provider configuration.
Solution
-
Verify if the custom domain is Auth0-managed or self-managed.
-
If the custom domain is Auth0-managed, contact Auth0 Support.
-
If the custom domain is self-managed, contact Cloudflare support to verify that no blocks are applied.