Deploy CLI Error "error: Unable to update enabled clients for databases: con_ID: Payload validation error: 'Array is too long (n), maximum 50'"

Overview

The following error is returned when attempting to deploy changes to a tenant's database connection:

 

error: Unable to update enabled clients for databases: con_ID: Payload validation error: 'Array is too long (n), maximum 50'

Applies To

  • Deploy CLI
  • Management API

Cause

This is due to using the deprecated attribute 'enabled_clients' for a given database connection, when attempting to run the update. This attribute has a limit of 50 entries, which explain the validation error returned by the Deploy CLI. The deprecated status of this attribute is called out in Update a connection under the Body Parameters header.

Solution

Due to this attribute being deprecated for performance reasons, the updated direction is to instead use these endpoints to enable/disable connections for given clients:

 

At this time the attribute 'enabled_clients' is planned to be deprecated in the future. Auth0 will provide notifications according to standard deprecation procedure.

Recommended content

No recommended content found...