SHA384 Hash Algorithm Error with New SAML Connections

Overview

When testing a new SAML connection, an error occurs with the message:

"hash algorithm 'http://www.w3.org/2001/04/xmldsig-more#sha384' is not supported"

Applies To

  • SAML 
  • Unsupported Hash Algorithm 

Cause

This error will occur if the SAML Response sent by the IdP to Auth0 is using an unsupported Hash Algorithm, in this case 'SHA384'.

Solution

Work with the identity provider to have the SAML Response use one of the supported hash algorithms:

 

Recommended content

No recommended content found...