Sender Domain has not Been Linked Error - Azure Email Provider

Overview

This article will explain a potential reason why email notifications, like "Verify your email address" emails, are not received from Auth0 when using Microsoft Azure Communication Services as a custom email service provider. The following error message is displayed in the tenant logs:

Error sending email: The specified sender domain has not been linked.

Applies To

  • Custom Email Providers
  • Azure Communication Services (ACS)

Cause

The cause of this issue may be that the Email Communication Services (ECS) resource was not configured and connected to the Azure Communication Services (ACS) resource before attempting to send emails.

Solution

Create an Email Communication Services (ECS) resource and connect it to the Azure Communication Services (ACS) resource before sending emails. Please have a look at the documentation references below:

If any difficulties are encountered with this configuration, it may be necessary to open a support ticket with Azure.

If the configuration has been correctly performed and this issue persists, then either post a question to the Community page (Free tenants) or create a Support Ticket for Auth0 (Trial / Paid subscription customers only).

Recommended content

No recommended content found...