The Error "The from address does not match a verified Sender Identity" is Received via Email after Setting Up Sendgrid as the SMTP Provider
Last Updated:
Overview
After setting up Sendgrid as the SMTP provider, passwordless emails are no longer being received. There are "Failed Notification" (type: fn) entries in the tenant logs with the following error description:
The from address does not match a verified Sender Identity. Mail cannot be sent until this error is resolved. Visit https://sendgrid.com/docs/for-developers/sending-email/sender-identity/ to see the Sender Identity requirements