The Error "The from address does not match a verified Sender Identity" is Received via Email after Setting Up Sendgrid as the SMTP Provider

Overview

After setting up Sendgrid as the SMTP provider, passwordless emails are no longer being received. There are "Failed Notification" (type: fn) entries in the tenant logs with the following error description:

The from address does not match a verified Sender Identity. Mail cannot be sent until this error is resolved. Visit https://sendgrid.com/docs/for-developers/sending-email/sender-identity/ to see the Sender Identity requirements

Cause
In the Email passwordless connection settings, the 'From' email was set to <root@auth0.com>.
Solution
Navigate to Dashboard > Authentication > Passwordless, click on Email and add an email address that is registered as a Sender Identity with Sendgrid in the 'From' field. 
 
Screenshot 2024-02-20 at 8.29.43 AM.png
 

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