Error Sending Email - Invalid Login: 534-5.7.9 Application-Specific Password Required
Sep 10, 2025
Overview
This article explain why emails do not send and the following error is seen in the tenant logs when using Gmail as an SMTP email provider.
Invalid login: 534-5.7.9 Application-specific password required
Applies To
- Google Email (Gmail)
- SMTP Provider
- Multifactor Authentication (MFA)
Cause
This issue is caused by multifactor authentication (MFA) being enabled for the account used in the email provider settings. The authentication cannot be completed as it is not an interactive flow.
Solution
In this scenario, an "Application specific password" is required to allow Auth0 to login to the Gmail SMTP account to send emails programmatically.
- This Google Support answer reviews how to set up an application-specific password in Google.
- Using an application-specific password in the tenant's email provider settings should resolve the error.