Forgot Password Does Not Work for Re-Invited Tenant Members

Overview

This article clarifies why a password reset email is not delivered when a re-invited Tenant Member attempts to use the Forgot password option during the login process. The re-invitation process is used to switch Tenant Members from Google accounts to an email/password connection, but the user does not have a password for the email address.

Applies To
  • Tenant Members
  • Forgot Password
  • Email/Password Connection
  • Google OAuth 2.0 (OAuth2)
Cause
The tenant members/Dashboard users do not have an email/password account created previous to accepting the invitation. 
Solution

If re-invited Tenant Members have not previously signed up with an email/password account, they must create their account before accepting the tenant invitation.

The official documentation clarifies the required sequence:

When the invited user selects the link to accept the invitation, the user is asked to log in with the invited email address. The user can then choose to log in with a social provider or log in with an email address and password. If the user chooses to log in with an email address and password, the user must have already created an account with Auth0, or the user must Sign up first and then accept the invitation again.

Related References

Recommended content

No recommended content found...