Getting Error "Domain example.com is not allowed to send: request limit exceeded, try again after <date>"

Overview

This article addresses an error that occurs when emails fail to deliver. The Auth0 tenant logs display the following error message:

Domain <example.com> is not allowed to send: request limit exceeded, try again after <date>

In this error, <example.com> represents the receiver's domain. This issue occurs when the Mailgun email provider is configured in Auth0.

Applies To

  • Email notifications
  • Mailgun email provider

Cause

This error is a rate limit error sent by Mailgun when emails to a specific domain exceed a threshold.

Solution

To resolve this issue, one of the following actions is required:

  • Contact Mailgun to request an increase for the domain's sending limits.
  • If the limits cannot be increased in the short term, consider switching to a different email provider in Auth0 temporarily.

Recommended content

No recommended content found...