Error 400 Occurs When Patching a Universal Login Page Template

Overview

An Error 400 occurs when attempting to patch a New Universal Login Page Template using the /api/v2/branding/templates/universal-login endpoint. The following error message may be returned:

Data does not match any schemas from 'oneOf'

Applies To

  • Universal Login
  • Branding API

Cause

This error has two primary causes:

  • The auth0:widget element is incorrectly placed in the <head> section of the HTML template instead of the <body> section.
  • The page template exceeds the maximum allowed size of 102,400 characters.

Solution

To resolve the error, verify the following:

  • The auth0:widget element is placed within the <body> section of the HTML template.
  • The total size of the page template does not exceed 102,400 characters.

 

If the error persists, it may be due to a JSON payload issue with the API. Follow these steps to recover:

  1. Delete the existing template.
  2. Set a new template using an HTML payload. NOTE: The set template API supports an HTML payload when the content-type is set to text/html.

Recommended content

No recommended content found...