Insufficient scope errors when accessing tenant management API
Last Updated:
Overview
This article explains why the following error occurs when attempting to use an access token for a request that requires a specific grant after using the client credentials grant:
Insufficient scope, expected any of: read:signing_keys
Applies To
- Management API
- Client Credentials Grant
- Hooks
Cause
The error occurs because the returned access token has no scope due to a misconfiguration in the client credentials exchange hook.
Solution
- Navigate to Auth Pipeline > Hooks.
- Locate the Client Credentials Exchange hook.
- Disable or edit the script to correct the configuration.