Invalid Request Error Occurs When Configuring the signingCert Attribute for a SAML2 Web App Add-On
Last Updated:
Overview
This article explains why the following error occurs when configuring the signingCert attribute for a Security Assertion Markup Language (SAML) 2 Web App Add-on:
invalid_request: error:1E08010C:DECODER routines::unsupported
Applies To
- SAML 2 Web App Add-on
- SAML Assertion Attributes
- SAML
- Connections
Cause
This error occurs because the signingCert attribute is configured with a value that is in an incorrect format.
Solution
To resolve this issue, the signingCert attribute must be formatted correctly.
Of particular note is that a '\n' character is required at the end of each line of the certificate value, including the first and last lines.
For example, refer to the documentation on SAML Assertion Attributes.