Login Behaves in Unexpected Way when Using Browser Incognito Mode
Sep 10, 2025
Overview
Applies To
- New Universal Login
- Incognito Mode
- Chrome Browser
Cause
This is how incognito mode in Chrome operates:
- "In Incognito, none of your browsing history, cookies and site data, or information entered in forms are saved on the device. This means that the activity does not appear in the Chrome browser history so that people who also use your device will not see your activity."
The most likely explanation for the observed behavior is that the particular login flow requires access to 3rd party cookies.
Solution
Go into the Chrome browser settings and select the option Allow third-party cookies in incognito.
- On the computer, open Chrome.
- At the top right, click More Settings.
- Under Privacy and security, click Cookies and other site data.
- Select an option:
- Allow all cookies.
- Block all cookies (not recommended).
- Block third-party cookies in Incognito.
- Block third-party cookies.
Make sure that the option '"Block third-party cookies in Incognito" is not selected.
- Select the option Allow all cookies and try the login flow again.
These instructions relate to the Chrome browser. If using a different web browser, such as Firefox incognito mode, MS Edge, or Apple Safari, then follow the guidance provided by the browser vendor.
If assistance to create a support ticket is needed, a video of the login flow in incognito mode would be very helpful. NOTE: Only Trial customers and customers with a Paid subscription are permitted to create support ticket requests.