Management API Global Limit Preventing Administration via Terraform
Last Updated:
Overview
Using the Auth0 Terraform provider to configure tenants may result in an error after a single loop of terraform plan and terraform apply. This error prevents further changes from being applied.
"Error: 429 Too Many Requests: Global limit has been reached"
Applies To
- Auth0 Terraform Provider
Cause
This issue is caused by a known problem in the Auth0 Terraform provider that incorrectly logs or triggers a global rate limit.
Solution
The fix for this rate limit issue is included in the official release v1.0.0-beta.2 and may also be available in newer pre-release versions.
-
Update the Auth0 Terraform provider to version
v1.0.0-beta.2or a newer version. -
After updating, run the
terraform planandterraform applyoperations again.
NOTE: A similar issue is logged in the Github repository for the provider.