Mixpanel Log Stream Fails with Error "Authenticated user does not have permission"
Last Updated:
Overview
After setting up a Mixpanel log stream, the following error occurs:
"code": "401",
"message": "Unauthorized",
"details": "{\"error\":\"Authenticated user does not have permission \...
Applies To
- Mixpanel Log Stream
Cause
The error occurred due to the credentials being used.
Solution
After getting new credentials with an "Admin" role, the log stream no longer produced this error.
The Username and Secret credentials created on the Mixpanel side need to be for a user with the role of at least "Admin".