'Name' and 'Email Address' Attributes Missing in Apple Connection User Profile

Overview

This article clarifies why the user profile created in the Auth0 tenant after a user performs "Sign in with Apple" is missing the 'name' and 'email address' attributes, even though the account is created successfully in Auth0.

Applies To
  • Apple connection

  • User profile attributes

  • "Sign in with Apple"

Cause

Several factors can cause the 'name' and 'email address' attributes to be missing from the user profile:

  1. The configuration uses the Auth0 Developer Key for the Apple connection, which is not recommended. Consult documentation on Devkeys.

  2. The 'name' and 'Email Address' attributes are not correctly enabled in the Apple connection under the Settings tab. (See below)

Apple Connection Settings tab - Attributes "Name" and "Email Address" checked

  1. Apple does not send the 'email' and 'name' attributes to the client (Auth0) in some scenarios. For example, the email value may be empty for Sign in with Apple at Work & School users. Consult Apple documentation on [Authenticating Users with Sign in with Apple].
Solution

To minimize the occurrence of this issue, follow the steps to ensure the attributes are correctly enabled and cached data is updated:

  1. Disable the 'name' and 'Email Address' attributes in the Apple connection Settings.

  2. Select Save to apply the change.

  3. Re-enable the 'name' and 'Email Address' attributes.

  4. Select Save to apply the change.

  5. Delete the Apple connection user profile from the Auth0 tenant.

  6. The user must Log in again with the same credentials to re-create the user profile in the Auth0 tenant.

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