Error When Opening Passwordless Magic Link From A Different Browser
Feb 20, 2026
Overview
When a user attempts to open a passwordless magic link from a different browser than the one used to request it, the following error message appears:
Something Went Wrong
The link must be opened on the same device and browser from which you submitted your email address.
Applies To
- Passwordless
- Universal Login
Cause
The tenant flag "allow_magiclink_verify_without_session" is set to false.
Solution
Make a PATCH request to the Management API to set the tenant flag to true using the following endpoint and payload:
/api/v2/tenants/settings
{
"universal_login": {
"passwordless": {
"allow_magiclink_verify_without_session": true
}
}
}