Password Reset Ticket Endpoint Fails With "User does not exist" Error on Custom Database Connection

Overview

This article provides a solution for an error that occurs when attempting to generate a password reset ticket using the Management API. The action fails for a user on a Custom Database connection where import mode is disabled or has been recently enabled.

{

"statusCode": 404,

"error": "Not Found",

"message": "The user does not exist",

"errorCode": "inexistent_user"

}

Applies To

  • Custom Database
  • Password Reset Ticket

Cause

The Password Reset Ticket endpoint triggers the Get User script when called for a <user_id> associated with a Custom Database connection in the following scenarios:

  • The Custom Database has import mode disabled.
  • The Custom Database has import mode enabled, but the user has not signed in successfully since the mode was enabled. This means the user has not been migrated.

The Get User script uses the email address associated with the <user_id>. The "user does not exist" error occurs if this email value does not return a user profile from the Get User script.

Solution

  • Verify that the Get User script can locate the email address associated with the <user_id> in the legacy system. Use Action Logs to inspect the values passed when the password-change endpoint is called. For more information, refer to Actions Real-time Logs.
  • If the user has been deleted from the legacy database while the connection is being migrated to Auth0 (import mode enabled), perform the following steps:
    1. Check the existing <user_id> for any metadata that needs to be preserved.
    2. Delete the existing account.
    3. Create a new account for the user.

Recommended content

No recommended content found...