SCIM Error Failed to Match an Entry in the Source and Target Systems

Overview

This article explains why the following error occurs when attempting to provision a user through the Azure admin user interface (UI):

Failed to match an entry in the source and target systems. We are not able to deserialize the resource received from your System for Cross-domain Identity Management (SCIM) endpoint because your SCIM endpoint is not fully compatible with the Azure Active Directory (Azure AD) SCIM client. Here is the resource we received from your SCIM endpoint.

Applies To

  • SCIM
  • Azure AD
  • Security Assertion Markup Language (SAML)

Cause

This error occurs when a change is made to the attribute used for the user ID, causing the unique identifiers to become inconsistent between the source and target systems.

For example, by default userPrincipalName is sent as userName. If this mapping changes to another attribute, for example, objectID, errors can occur for previously provisioned users. The system can find these users by email, but the userName values no longer align.

Solution

If the attribute used for the unique user identifier in the Azure attribute mapping configuration changes, delete the existing users in the target system. This action is necessary to resume provisioning and prevent conflicts from previously existing users who were provisioned with a different identifier.

Related References

Recommended content

No recommended content found...