Failed Silent Authentication (FSA) Logs with "Login required" Error

Overview

This article explains the most likely cause for a large number of the following Failed Silent Authentication (FSA) error in the Auth0 logs from GET /authorize calls:

Login required

 

Applies To
  • Failed Silent Authentication (FSA)
  • Management API
  • Failed Login
Cause

Usually, this error is caused by a misconfiguration of the Silent Authentication flow or a bug.

  • A common error with Silent Authentication is when the user is not prompted to the Login page after having a "login_required" error. Therefore, it loops in an endless login failure.
  • To troubleshoot this issue, review the code implementation and error handling after the getTokenSilently() method in JS or a similar method in other SDKs. 
Solution

Handle the login error in the response as described in the document Configure Silent Authentication:

login_requiredThe user was not logged in at Auth0, so silent authentication is not possible. This error can occur based on the way the tenant-level Log In Session Management settings are configured; specifically, it can occur after the time period set in the Require log in after setting. See Configure Session Lifetime Settings for details.
consent_requiredThe user was logged in at Auth0 but needs to give consent to authorize the application.
interaction_requiredThe user was logged in at Auth0 and has authorized the application but needs to be redirected elsewhere before authentication can be completed, for example, when using a redirect rule.

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