Terraform Resource Creation Fails with 403 Forbidden Error

Overview

This article clarifies the reason for the following error when attempting to create or deploy a Terraform resource to an Auth0 tenant, even when the Machine to Machine (M2M) application has full access and all steps from the Terraform documentation are followed:

Error: 403 Forbidden: The account is not allowed to perform this operation, please contact our support team.

Applies To

  • Terraform
  • Machine to Machine (M2M) Application
  • 403 Forbidden Error
  • Subscription Tiers

Cause

This error message typically occurs if the customer is trying to update resources that were are included in their current subscription.  For example, the error appears if the user attempts to deploy the "auth0_branding" in the Free tier.

Solution

To resolve this issue, use one of the following options:

  • Exclude the resources that are not included in the current subscription.

  • Update the Auth0 subscription so the necessary features and resources are enabled and can be configured by the Terraform provider as expected.

Recommended content

No recommended content found...