Two-factor authentication is required to access this application

Overview

After completing the authentication flow, the user is redirected to an error page stating:

Something Went Wrong
Two-factor authentication is required to access this application. To enable this, please contact your system administrator.

The tenant's Authentication Profile settings are set to Identifier + Password, but the WebAuthn platform is enabled as the first factor on the profile.

Additionally, under the MFA settings, WebAuthn FIDO devices are set as disabled, which means no WebAuthn factors are available for first-factor usage.

Applies To
  • Two-factor authentication 
Cause

WebAuthn, as the first factor, was enabled despite Identifier First + Biometrics being turned off in the tenant's Authentication Profile.

Solution

Reset the proper Authentication Profile configuration by toggling the settings below:

  1. In the dashboard, go to Authentication > Authentication Profile
  2. Toggle this to either Identifier First or Identifier First + Biometrics, and select Save
  3. Toggle the setting back to Identifer First + Password, and select Save

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