User Import Without Password Hashes

Overview

When re-importing users with a custom_password_hash the following error is received.

 

A custom_password_hash was provided, but the user already has password hash defined.

 

Applies To
  • User Import
  • Password Hashes
Cause

After a user is imported without a password, it is not possible to update the password_hash attribute on a subsequent import. This would be an upsert operation; see Bulk User Import Schema and Examples for further details on upserts.

Solution

The custom_password_hash attribute is update-able. For this to work, the following should apply:

  • custom_password_hash attribute was used on the initial import
  • The user has not logged in with the account yet.

The password_hash can only be set on initial import.

If the user has not logged in yet and the password import is causing the reported error, then the user would have to be deleted and imported with new values.

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