Verification Email Flow Leads to Error Page Instead of Redirecting to Custom URL

Overview

When requesting a verification email to be sent to the user through a Management API SDK, the end-user receives the verification link, but when they access the link they see the error invalid result url instead of being redirected to a client application specific redirect URL. The error indicates that the email was actually verified with success, however, the overall flow still fails.

In addition to the error page a tenant log is generated:

 { "type": "fv", "description": "invalid result url: /[optional_path_component]?supportSignUp=true&supportForgotPassword=true&email=[redacted_email_address]&message=Your%20email%20was%20verified.%20You%20can%20continue%20using%20the%20application.&success=true&code=success", // other properties }
 
Applies To
  • Management API SDK
Cause
The client application associated with the request that triggers the email verification ticket link to be generated does not have any allowed callback URL defined so the email template placeholder application.callback_domain is an empty value which then triggers an invalid result URL.
Solution
Ensure that the email verification request is performed in association with a client application that defines at least one allowed callback URL. Accomplish this by ensuring that the underlying API request includes a suitable client identifier parameter in the request body if the endpoint supports it or ensure that the client assumed by default by the endpoint is the expected one. Alternatively, update the email template result URL to not depend on the application.callback_domain email placeholder.

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