Attempting to Enable Import Mode Returns Error: 'You Cannot Change "options.enabledDatabaseCustomization" setting'

Overview

If a database connection contains users, attempting to enable Automatic Migration and connect to an external database returns the following error in the Dashboard: 

Error! This database contains users. You cannot change "options.enabledDatabaseCustomization" setting.

Applies To

  • Import Mode
  • Automatic Migration

Cause

Using Automatic Migration to migrate users from an external database into a regular database that has existing users is not supported. 
 

Solution

Rather than attempting to enable Automatic Migration when users already exist, the alternatives would be to import the users through Bulk User Import or to use a second database connection to import the users through automatic migration.

 

Recommended content

No recommended content found...