Resolve 500 Internal Server Error Due to Incorrect Vercel Configuration
Last Updated:
Overview
A 500 Internal Server Error occurs when deploying an application to Vercel, even though the application functions correctly in a local environment. The error is a result of the application’s Software Development Kit (SDK) failing to instantiate correctly.
The Vercel logs may contain the following error message:
“issuerBaseURL” must be a valid uri
Applies To
-
Vercel deployment
-
Application using Auth0 Software Development Kit (SDK)
-
Configuration variable errors
Cause
Vercel reads the application's configuration variables incorrectly, which causes errors when the application attempts to use the Auth0 SDK.
Solution
Perform the following steps to resolve the incorrect configuration:
-
Remove all configuration variables from Vercel.
-
Re-add the configuration variables to Vercel.