Auth0 Error Occurs When Populating Email Template Redirect To Field

Overview

When configuring an email template in a free Auth0 tenant, an error occurs when populating the Redirect To field because Auth0 requires a verified custom domain. Resolve this issue by adding a custom domain to the tenant and updating the email template.

Auth0 generates an error when a user attempts to populate the Redirect To field in an email template:

Error! There must be a verified custom domain to perform this operation

email template error 

Applies To
  • Auth0
  • Free Tenants
  • Email Templates
Cause

For free subscription plans, Auth0 requires a verified custom domain to use the Redirect To field in email templates due to a security update. Older tenants might not experience this requirement.

Solution

What steps add a custom domain to resolve the email template error?

To resolve the error, add a custom domain to the free tenant from the Branding menu and update the email template.

  1. In the Auth0 Dashboard, navigate to Branding > Custom Domains.
  2. Select Add Custom Domain, enter the required data, and select Save.
  3. Navigate to Branding > Email Templates.
  4. Update the Redirect To field in the email template.

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