Auth0 Organization Invitation Disappears Without Being Accepted

Overview

An Auth0 organization invitation disappears when a user attempts to accept it while logged in with an incorrect account. To resolve this issue, create a new invitation and ensure the user accepts it using the correct credentials. The organization invitation disappears from the Auth0 data store and tenant dashboard even though the invitation is not deleted or expired, and the invited user is not added to the organization.

Applies To
  • Auth0
  • Organization Invitations
Cause

Auth0 removes an organization invitation from the data store and tenant dashboard under the following conditions:

  • An administrator deletes the invitation via the Management API or revokes it from the dashboard.

  • The invitation expires. When an administrator creates the invitation via the Management API, a ttl_sec value specifies the expiration. If ttl_sec is unspecified or set to 0, the value defaults to 604800 seconds (7 days). When an administrator creates the invitation via the tenant dashboard, the default 7-day expiration applies.

  • The user successfully accepts the invitation and Auth0 adds the user to the organization.

  • The user fails to accept the invitation. For example, Auth0 creates the invitation for <user@example.com>, but the user attempts to accept the invite while logged in as <another_user@example.com>. Auth0 consumes the invitation, but does not add the user to the organization. This event generates a fi (Failed Invite accept) event in the tenant logs, with the following error message:

     

    the specified account is not allowed to accept the current invitation

     

    The log also includes details regarding the invited user and the actual logged-in user.

Solution

How is the missing organization invitation resolved?

To resolve the missing organization invitation, create a new invitation and ensure the user accepts it using the correct account.

  1. Create a new organization invitation.
  2. Instruct the invited user to accept the invitation with the correct account. The user must log out of the existing account before opening the invitation link, or open the invitation link in an incognito browser window.

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