Auth0 End-of-Life Rollout: Unrestricted Offset Pagination in Connections Management API

Overview

The end-of-life date for unrestricted use of offset pagination in the connections Management API was October 27, 2025. After this date, the deprecated behavior will gradually become unavailable. The process to remove access to the deprecated behavior has the following phases:
  • December 2, 2025 - Remove access for development or staging tenants based on their environment tag. Once rollout is complete, changing a development tenant to production will not restore access to the deprecated behavior.
  • February 9, 2026 - Update remaining tenants, including production, to default to the new behavior. The Dashboard migration toggle, Unrestricted offset pagination in Connections Management API, allows temporary reversion until the next phase.
  • March 23, 2026 - Remove access for all tenants; includes removing the ability to revert via migration toggle.

The end-of-life rollout ended on May 21, 2026, and as of that date, all tenants had transitioned to the non-deprecated behavior. The corresponding migration toggle is no longer available in the Auth0 Dashboard (Tenant Settings > Advanced) as the updated behavior is now effective and permanent for all Auth0 tenants.

With the new behavior, requests to the Management API get all connections endpoint using offset-based pagination will fail and return an error response if the calculated result page exceeds the limit of 1000. For example, the service returns the error response shown below when using the page=30&per_page=50 or page=15&per_page=100 parameters because, in both situations, multiplying the number of records requested per page by the requested page index plus one (to account for the page index being zero-based) results in the request exceeding the initial 1000 connections.

{
  "statusCode": 400,
  "error": "Bad Request",
  "message": "The requested page exceeds the record maximum. Offset pagination can only return the first 1000 records from your tenant. To fetch records beyond this maximum, use checkpoint pagination.",
  "errorCode": "invalid_paging"
}

According to the above, with a page size of 50, the last page index available without an error is 19 (page=19&per_page=50). With the maximum page size of 100, the last page index available is page index number 9 (page=9&per_page=100).

It's relevant to note that parameter combinations that surpass the limit trigger the error even if the tenant associated with the request has fewer than 1000 connections.

 

Applies To

  • Connections
  • Management API
  • End of Life (EOL)

Cause

The service restricted offset pagination to a maximum of 1000 connections as part of a calendar year 2025 scheduled change, because the alternative checkpoint-based approach is more efficient, particularly for larger datasets.

On April 29, 2025, Auth0 announced the deprecation of the previous service behavior. The information provided in the original announcement is available in the respective Dashboard and Support Center notification.

Solution

Management API integrations needing more than 1000 connections must use checkpoint-based pagination (from and take parameters) instead of offset-based pagination. This may require updating Auth0 SDKs and tools. For example, the Auth0 Deploy CLI uses checkpoint-based pagination from v8.7.0 onward, so older versions need to be updated.

Do not use the deprecated Auth0 User Import/Export extension; it may fail because it relies on offset-based pagination. For tenants with fewer than 100 connections, use the user import/export feature in the Auth0 Dashboard. For tenants with more than 100 connections, use Management API endpoints to create user import and export jobs.

Recommended content

No recommended content found...