How to Unblock a User That Does Not Exist in the Tenant

Overview

Auth0's Brute Force Protection feature will block login attempts even if the user enters credentials that do not correspond to a user profile. This can be especially confusing in situations where custom database scripts are in use, because the user is blocked but not yet present in the tenant.

Applies To
  • Custom Databases
  • Attack Protection
Cause

This is an intended security measure meant to protect a tenant from user enumeration.

Solution

In cases such as these, the user can be unblocked using the Management API, more specifically, the "Delete User Blocks" endpoint:

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