Unable to Switch Users Due to Seamless Auth0 SSO Login Loop

Overview

A user attempts to switch to a different account in an application but is stuck in a login loop. After logging out and returning to the login page, Seamless Single Sign-On (SSO) automatically authenticates the previous user and forces a login, preventing the use of a different account.

Applies To
  • Seamless Single Sign-On (SSO)
  • Auth0
  • Identity Provider (IdP)
Cause

The problem occurs because the user is not logged out of the Identity Provider (IdP) during the application logout process. If the IdP session is not terminated, the browser re-establishes the session on the next login attempt, creating a loop.

Solution

Configure the application to log the user out of the upstream IdP when the application session ends. Initiate a request to the Auth0 Logout endpoint to terminate the session.

 

Related References

 

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