API Not Found when Registering M2M Application

Overview

Currently, there is an issue if a customer has more than 100 APIs. When registering an API to a Machine-to-machine (M2M) application, only the first page of 100 is available to search on.

Applies To
  • Machine-to-machine (M2M)
Cause

This can happen when there are too many APIs to search through. This can happen if the result is not in the first 100 responses. The team is working on an improvement for this but there is no ETA. 

Solution

Workaround:
To resolve this using the API to associate the API and client, see below.

If the M2M application is not created, create the application first with a payload similar to this. The rest of the changes can be made in the UI after creation:  Create a client

 {
"name":"AppName",
"app_type":"non_interactive"
}

Associate the API needed via this endpoint: Create client grant

The recommendation for this endpoint is to use the matching GET call (Get client grants) to see a sample of an existing client grant to correctly format the requests. Include the client_id of the application being updated, the API's audience, and an array of scopes that should be associated. Update the scopes in the UI after this is associated as normal, so only one scope is necessary at creation.

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